From J.W.R.deGoede@ITS.TUDelft.NL Mon Mar  1 14:03:58 1999
Date: Mon, 01 Mar 1999 16:18:58 +0100 (MET)
Date: Tue, 02 Mar 1999 10:10:45 +0100 (MET)
Subject: Re: linux vgb

[This document has been made of several emails I got from Hans. It has
been slightly edited and unrelevant parts have been removed. -- Marat]


The problem with VGB on GLIBC systems, at least on RedHat 5.x is that vVGB
is linked against libc5. This in itself is not a problem since RedHat
ships with libc5 backward compatibility. The problem is however that most
of Marat's emus use ZLib. Which is a nice feature, but unfortunately
RedHat has decided not to include ZLib in the libc5 backward compatibility
package. The linker instead of at least issuing a warning or aborting just
takes the libc6 linked ZLib which is available -> core. 

The fix is easy:

1)  Get a libc5 linked ZLib and put it in /usr/i486-linux-libc5/lib.
2)  Run ldconfig.

and VGB/MasterGear/iNES should work fine.


I have a clean RedHat 5.2 system over here running the latest VGB binaries
for Linux from As expected, running VGB
dumps core immediately due to the ZLib problem. The attached file archive
should fix it. This has been verified on a clean RedHat 5.2 install:


To install the fix, type as root:

1)  tar xvfzpP Linux-Bug-Fix.tar.gz
2)  ldconfig

And now enjoy VGB, iNES, etc.

Regards, Hans

From Mon Mar  1 21:19:36 1999
Date: Mon, 1 Mar 1999 19:26:58 -0500
Subject: iNES and libc5 zlib fix

[This is a followup from Jeffrey Grady who succesfully fixed the problem
on his RedHat setup. -- Marat]


You can find RedHat 4.2 RPMs at: /pub/linux/redhat/redhat-4.2/i386/RedHat/RPMS/

Here's the way I solved the problem on my RedHat 5.2 system:

1)  rpm -iv zlib-1.0.4-1.i386.rpm
2)  cp /usr/lib/ /usr/i486-linux-libc5/lib/
3)  cd /usr/i486-linux-libc5/lib/
4)  ln -s
3)  rpm -e zlib-1.0.4
4)  /sbin/ldconfig
5)  Yay!  iNES doesn't dump core on RedHat 5.2!

Crude, but effective. :) If you've got a cleaner way to do it, I'd like to
hear about it. 

I also submitted a bugreport to RedHat on their Bugzilla database about
the lack of a libc5 ZLib library. It's bug #1392, for anyone who cares... 


Jeff Grady